股民大家庭

 找回密码
 立即注册

扫一扫,访问微社区

搜索
查看: 707839|回复: 3

[通达信公式] 通达信DMI新编(强、买入)副图源码指标公式

[复制链接]
发表于 2019-6-29 09:30 | 显示全部楼层 |阅读模式
2019-06-29_092545.png


TR1:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),21);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EMA(IF(HD>0 AND HD>LD,HD,0),21);
DMM:=EMA(IF(LD>0 AND LD>HD,LD,0),21);
PDI:= DMP*100/TR1;
MDI:= DMM*100/TR1;
ADX: EMA((PDI-MDI)/(MDI+PDI)*100,6)*2;
ADXR:EMA(ADX,6);
ADMA:EMA(ADX,20);
OMD:(ADX-2*ADMA+ADXR)/2, COLORSTICK;
DRAWBAND(ADX,RGB(155,50,50),ADXR,RGB(0,100,50));
STICKLINE(OMD>REF(OMD,1) AND OMD>0,0,OMD,1,0),COLORRED;
STICKLINE(OMD>REF(OMD,1) AND OMD<0,0,OMD,1,0),COLORGREEN;
STICKLINE(OMD<REF(OMD,1),0,OMD,1,0),COLORCBCBC0;
STICKLINE(OMD>=0 OR OMD<=0,0,0,50,1),COLORWHITE;
ADX1:ADX,COLORRED;
ADXR1:ADXR,COLORGREEN;
ADMA1:ADMA;
强:IF(ADX1>=ADXR1,ADX1,DRAWNULL),COLORRED,LINETHICK3;
买入:IF(OMD>0 AND OMD-REF(OMD,1)>0,30,0);
110;
0;
-110;



上一篇:通达信黎明前的黑暗副图/选股源码指标公式
下一篇:通达信筹码分析主图 源码指标公式
发表于 2019-6-30 20:37 | 显示全部楼层
谢谢分享
回复

使用道具 举报

发表于 2019-11-1 10:57 | 显示全部楼层
谢谢分享!!!!!
回复

使用道具 举报

发表于 2020-2-3 22:00 | 显示全部楼层
谢谢分享
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

今日股市|网站地图|股民学校|手机版|小黑屋|股民大家庭 ( 湘ICP备19003735号 )24小时在线客服

GMT+8, 2020-6-2 10:44 , Processed in 1.795103 second(s), 31 queries .

Powered by 股民大家庭

© 2007-2020 http://www.gupiao168.com

快速回复 返回顶部 返回列表