股民大家庭

 找回密码
 立即注册

扫一扫,访问微社区

广告,该站的任何行为,与本站无关广告,该站的任何行为,与本站无关广告,该站的任何行为,与本站无关广告,该站的任何行为,与本站无关
搜索
查看: 1479|回复: 1

[通达信公式] 通达信顶底高抛低吸副图源码指标公式

[复制链接]
发表于 2018-08-09 10:58:36 | 显示全部楼层 |阅读模式
高抛低吸(源码,副图,贴图)

用法说明  用月线周线判断最佳,特别是大盘更准,KD在抄底线以下金叉,强烈买进信号.周期越长越有效。

LC:=REF(CLOSE,1);

RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);

TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);

HD:=(HIGH - REF(HIGH,1));

LD:=(REF(LOW,1) - LOW);

DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);

DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);

PDI:=((DMP * 100) / TR1);

MDI:=((DMM * 100) / TR1);

ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);

AV:=(RSI5 + ADX);

DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);

0,COLORFF00FF;

WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));

NEWVOL:=(RSI5 - WR10);

阶段底部:=(AV + NEWVOL);

STICKLINE((阶段底部 < 0),0,-10,0.8,1),LINETHICK6,COLORYELLOW;

趋势线:=LLV(阶段底部,1),COLORWHITE,LINETHICK0;

STICKLINE(CROSS(阶段底部,0),0,-10,0.8,1),LINETHICK6,COLORRED;

STICKLINE((趋势线 >230 ),100,90,0.3,1),LINETHICK6,COLORGREEN;

LOWV:=LLV(LOW,9);

HIGHV:=HHV(HIGH,9);

RSV:=EMA((CLOSE-LOWV)/(HIGHV-LOWV)*100,3);

K:EMA(RSV,3);

D:MA(K,3);

STICKLINE(K>D , K,D ,2.5,0),COLORRED,LINETHICK2;

STICKLINE(D>K,K,D,2.5,0),COLORGREEN,LINETHICK2;

逃顶线:90,COLORGREEN;

中轴线: 50,COLORRED;

抄底线:10,COLORGREEN;

DRAWICON(CROSS(K,D),12,1)COLORRED;

DRAWICON(CROSS(D,K),88,2)COLORGREEN;

警戒:阶段底部 < 0,LINETHICK0,COLORYELLOW;

出击:CROSS(阶段底部,0),LINETHICK0,COLORRED;


选股公式:

LC:=REF(CLOSE,1);

RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);

TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);

HD:=(HIGH - REF(HIGH,1));

LD:=(REF(LOW,1) - LOW);

DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);

DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);

PDI:=((DMP * 100) / TR1);

MDI:=((DMM * 100) / TR1);

ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);

AV:=(RSI5 + ADX);

DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);

WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));

NEWVOL:=(RSI5 - WR10);

阶段底部:=(AV + NEWVOL);

出击:CROSS(阶段底部,0);

2018-08-09_105554.png
2018-08-09_105616.png
2018-08-09_105633.png
发表于 2018-08-12 18:32:02 | 显示全部楼层
谢谢分享
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

今日股市|网站地图|sitemap|股民学校|手机版|小黑屋|股民大家庭 ( 晋ICP备18009968号-1 ) 24小时在线客服

GMT+8, 2018-11-20 08:47 , Processed in 0.393911 second(s), 29 queries , Gzip On.

Powered by 股民大家庭

© 2007-2018 www.gupiao168.com


快速回复 返回顶部 返回列表