股民大家庭股票论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

广告,该站的任何行为,与本站无关
广告,该站的任何行为,与本站无关
广告,该站的任何行为,与本站无关
搜索
查看: 381|回复: 4

[通达信公式] 通达信牛股选股公式 牛股第二波选股公式副图源码

[复制链接]
发表于 2018-02-09 13:51:40 | 显示全部楼层 |阅读模式
通达信牛股选股公式 牛股第二波选股公式副图源码

通达信牛股选股公式 牛股第二波选股公式副图源码

通达信牛股选股公式 牛股第二波选股公式副图源码

以下通达信公式已经通过测试
通达信牛股选股公式源码

MAC_60:=C>MA(C,60) OR C=MA(C,60) OR CROSS(C,MA(C,60));
MAC_5:=C>MA(C,5) OR C=MA(C,5) OR CROSS(C,MA(C,5));
XG5_20:=MA(C,5)>MA(C,20) OR MA(C,5)=MA(C,20) OR CROSS(MA(C,5),MA(C,20));
XG10_20:=MA(C,10)>=MA(C,20) OR MA(C,10)=MA(C,20) OR CROSS(MA(C,10),MA(C,20));
XG5_10:=MA(C,5)>MA(C,10) OR MA(C,5)=MA(C,10) OR CROSS(MA(C,5),MA(C,10));
XG20_60:=MA(C,20)>MA(C,60) OR MA(C,20)=MA(C,60) OR CROSS(MA(C,20),MA(C,60));
XG5_60:=MA(C,5)>MA(C,60) OR MA(C,5)=MA(C,60) OR CROSS(MA(C,5),MA(C,60));
XG5_120:=MA(C,5)>MA(C,120) OR MA(C,5)=MA(C,120) OR CROSS(MA(C,5),MA(C,120));
XG10_60:=MA(C,10)>MA(C,60) OR MA(C,10)=MA(C,60) OR CROSS(MA(C,10),MA(C,60));
XG60_120:=MA(C,60)>MA(C,120) OR MA(C,60)=MA(C,120) OR CROSS(MA(C,60),MA(C,120));
XG10_120:=MA(C,10)>MA(C,120) OR MA(C,10)=MA(C,120) OR CROSS(MA(C,10),MA(C,120));
XG20_120:=MA(C,20)>MA(C,120) OR MA(C,20)=MA(C,120) OR CROSS(MA(C,20),MA(C,120));
B0001:=XG5_10 AND XG5_20 AND XG10_20 ;
B0002:=B0001 AND XG5_60 AND XG5_120 AND XG10_60 AND XG10_120 AND XG20_60 AND XG20_120 AND XG60_120 ;
VAR1:=EMA(EMA(CLOSE,13),13);
A0006:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
A10:=CROSS(A0006,0);
{通达信牛股选股公式}
A0001:=IF(A0006<0,A0006,0);
A0002:=IF(A10,5,0);
A0003:=IF(A0006>REF(A0006,1) AND A0006>0,A0006,0);
VAR2:=100*WINNER(CLOSE*0.95);
A0004:=IF(VAR2>50 AND COST(85)<CLOSE AND A0006>0,A0006,0);
A0005:=IF(A0006<REF(A0006,1) AND A0006>0,A0006,0);
Y0001:=MA(C,60)=REF(MA(C,60),1) OR MA(C,60)> REF(MA(C,60),1) OR CROSS(MA(C,60), REF(MA(C,60),1));
Y0002:=MA(C,120)=REF(MA(C,120),1) OR MA(C,120)> REF(MA(C,120),1) OR CROSS(MA(C,120), REF(MA(C,120),1));
VOLUME:=VOL;
MA5V:=MA(V,5);
MA35V:=MA(V,35);
MA135V:=MA(V,135);
MA60V:=MA(V,60);
C0001:=MA5V>MA35V OR MA5V=MA35V OR CROSS(MA5V,MA35V);
C0002:=MA5V>MA135V OR MA5V=MA135V OR CROSS(MA5V,MA135V);
C0003:=V>MA135V OR V=MA135V OR CROSS(V,MA135V);
C0004:=MA35V>MA135V OR MA35V=MA135V OR CROSS(MA35V,MA135V);
C0005:=C0001 AND C0002 AND C0004;
C0006:=V>MA60V OR V=MA60V OR CROSS(V,MA60V);
C0007:= C0002 AND C0004;
HSL:=VOL/CAPITAL*100;
S1:=IF(CODELIKE('300'),0,1);
S2:=IF(NAMELIKE('S'),0,1);
S3:=IF(NAMELIKE('*'),0,1);
S4:=DYNAINFO(17)>0;
ST:=S1 AND S2 AND S3 ;
XG11:=C<=20;
XG12:=XG20_60 OR XG20_120;
XG122:=XG5_60 OR XG5_120;
XG13:=CAPITAL<15000000;
{通达信牛股选股公式}
XG120:=XG5_120 AND XG5_60 AND XG20_60 AND XG20_120 AND XG10_120 AND XG10_60 AND (A0004 OR A0003>3);
XG1222:=XG120 AND A0005=0 AND C0007 AND C0006 ;
XG1:=B0001 AND (A0004 OR A0003>7) AND A0005=0 ;
XG2:=C0005 AND (A0004 OR A0003>3) AND A0005=0;
XG3:=B0002 AND (A0004 OR A0003>2) ;
{XG999:=B0002 AND C0005 AND (A0004 OR A0003>1) ;}
XG4:=(B0001 AND C0005) AND (A0004 OR A0003>2) AND A0005=0;
D0001:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1);
D0001》2.5%:=D0001>0.025;
D0001》4%:=D0001>0.04;
D0001》5%:=D0001>0.049 AND (A0004 OR A0003>2) ;
D0001》8%:=D0001>0.08 ;
XG5:=D0001》4% AND(A0004 OR A0003>3) AND XG12 AND C0007;
XG6:=D0001》2.5% AND (REF(A0002,1) OR REF(A0002,2)) AND B0001 AND (A0004 OR A0003>1.3);
XG7_1:=XG5_20 AND XG10_20 AND XG5_60 AND XG5_120 AND XG10_60 AND XG10_120;
XG7_2:=XG20_60 AND XG20_120 AND XG60_120 AND C0007 AND A0004 AND MAC_60 AND A0005=0;
XG7:=XG7_1 AND XG7_2 ;
Z0001:=(O>=REF(C,1)*1.099);
XG9_1:=((XG1 OR XG2 OR XG3 OR XG4 OR XG5 OR XG6 OR XG7) AND MAC_5) OR ((D0001》5% OR D0001》8%) AND A0006>0) ;
XG9:=XG9_1{ AND NOT(Z0001)};
XG10:=(XG9 OR XG1222 ) ;
VARX1:=(HHV(HIGH,5)-LLV(LOW,5));
VARX2:=(HHV(HIGH,9)-CLOSE);
VARX3:=(CLOSE-LLV(LOW,9));
VARX4:=VARX2/VARX1*100-70 ;
VARX5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VARX6:=(2*C+H+L)/4;
VARX7:=SMA((VARX3/VARX1*100),3,1);
VARX8:=LLV(LOW,34);
VARX9:=SMA(VARX7,3,1)-SMA(VARX4,9,1);
VARX10:= IF(VARX9>100,VARX9-100,0);
VARXA:=HHV(HIGH,34);
A0009:=EMA((VARX6-VARX8)/(VARXA-VARX8)*100,8);
BX1:=EMA(A0009,5);
A0007:=STICKLINE(A0009>0 AND A0009-BX1<0,-0.025,0,1,0),COLORRED;
A0008:=(A0009>0 OR CROSS(A0009,0))AND A0009-BX1>=0;
DIF:=EMA(CLOSE,9)-EMA(CLOSE,18);
DEA:=EMA(DIF,7),LINETHICK1;
MACDC1:=DIF>DEA OR DIF=DEA OR CROSS(DIF,DEA);
MACDC:=MACDC1 AND (DEA>0 OR DEA=0 OR CROSS(DEA,0));
XG71:=A0004 AND (MACDC1 OR A0008);
XG72:= A0003>5 AND A0008 AND MACDC AND MAC_5 AND (B0001 OR B0001) AND A0005=0;
XG73:=(XG71 OR XG72) ;
XG74:={XG73 AND}(A0004 OR A0003>2.5) AND (A0008 OR MACDC1);
XG75:=A0003>9;
{通达信牛股选股公式}
XG76:=C0005 AND (MACDC1 OR A0008);
XG77:=MACDC1 AND MACDC;
KP1:=A0006>0 AND CROSS(VAR2,50) AND COST(85)<CLOSE;
KP2:=A0006>0 AND CROSS(CLOSE,COST(85)) AND VAR2>50;
KP3:=VAR2>50 AND COST(85)<CLOSE AND CROSS(A0006,0);
KP4:=KP1 OR KP2 OR KP3;
KP5:=KP4 AND A0005=0;
XG:XG9 ;



上一篇:通达信成交量指标公式副图源码
下一篇:通达信超级短线指标选股副图源码带预警无未来
发表于 2018-02-09 14:49:39 | 显示全部楼层
谢谢分享
回复

使用道具 举报

发表于 2018-02-09 17:17:55 | 显示全部楼层
谢谢分享
回复

使用道具 举报

发表于 2018-02-10 01:33:13 | 显示全部楼层
感謝分享~~
回复

使用道具 举报

发表于 2018-02-14 08:01:22 | 显示全部楼层
谢谢分享
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

广告合作|VIP中心|网站地图|sitemap|手机版|小黑屋|archiver|股民大家庭 ( 辽ICP备17012147号-1 ) 24小时在线客服

GMT+8, 2018-2-21 05:13 , Processed in 1.228128 second(s), 35 queries , Gzip On.

Powered by Discuz! X3.2

© 2007-2017 Comsenz Inc.

股民大家庭股票论坛中国最大最好的股票论坛,11年专注股票论坛,专业提供股票交流股票软件股票公式等。
股民大家庭主要提供股票知识股票入门基础知识以及股票入门书籍知识学习的股票论坛
声明:股民大家庭上所有广告均为外来广告,所有的广告行为均与本站无关。
本站所有资讯均来源于网络,不作投资依据,仅供参考,据此入市,风险自担!
快速回复 返回顶部 返回列表