股民大家庭股票论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

广告,该站的任何行为,与本站无关
广告,该站的任何行为,与本站无关
广告,该站的任何行为,与本站无关
广告,该站的任何行为,与本站无关
广告,该站的任何行为,与本站无关
搜索
查看: 744|回复: 4

[通达信公式] 通达信控盘指标:控盘趋势指标公式

[复制链接]
发表于 2018-1-1 22:06 | 显示全部楼层 |阅读模式
通达信控盘指标:控盘趋势指标公式

以下通达信公式已经通过测试

通达信控盘指标源码:

{控盘趋势}
ZLCM:=EMA(WINNER(CLOSE)*70,3);{//主力筹码估算}
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);{//散户筹码估算}
ZSHTL:=SHCM/(ZLCM+SHCM)*100;{//散户套牢筹码比率}
ZZLKP:=ZLCM/(ZLCM+SHCM)*100;{//主力控盘筹码比率}
主力控盘系数:=INTPART(ZZLKP),COLORCYAN;
轴:=50,COLORGREEN,DOTLINE,LINETHICK1;
DRAWTEXT(CROSS(主力控盘系数,轴),轴+10,'↖高控盘'),COLORYELLOW;
{指标说明:资金流入强度下穿0轴,股票必抛};
N:=10;
AN:=MA(C,N);
AN12:=MA(AN,12);
A1:=L<AN;
A2:=C>AN;
A3:=C/REF(C,1)<AN;
A4:=CROSS(C,AN) AND V/REF(MA(V,5),1)>1.016;
XG:=A1 AND A2 AND A3 AND A4;
STICKLINE(AN>=AN12 AND XG,H,L,2,0),COLORLIRED;
STICKLINE(AN<AN12 AND XG,H,L,2,0),COLORLIGREEN;
{DRAWICON(XG,H,13);}
DDKP:=EMA((WINNER(CLOSE) * 70),3);
WWKP:=EMA(((WINNER((CLOSE * 1.1)) - WINNER((CLOSE * 0.9))) * 80),3);
主力控盘:=((DDKP / (DDKP + WWKP)) * 100),LINETHICK1,COLORWHITE;
顶:90, LINETHICK2 ,COLORRED;
风险:80,,COLORYELLOW; 平衡:50,COLORGREEN;
安全:20,COLORBLUE;
底:0, LINETHICK2 ,COLORWHITE;
A:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19);
B:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
D:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4);
长线:A+100,COLOR9900FF,LINETHICK2;
秒线:=B+100,COLOR888888;
短线:D+100,COLORYELLOW,LINETHICK2;
见顶:=((REF(短线,1)>85 AND  REF(秒线,1)>85 AND REF(长线,1)>65) AND CROSS(长线,秒线));
顶域:=(短线<REF(短线,1) AND REF(短线,1)>80) AND (REF(秒线,1)>95 OR REF(秒线,2)>95 ) AND 长线>60 AND 秒线<83.5
AND 秒线<短线 AND 秒线<长线+4,COLORGREEN;
顶部:=FILTER(顶域,4);
STICKLINE( {见顶 OR} 顶部,99,103,20,1 ),COLORGREEN,LINETHICK2;
底域:=(长线<12 AND 短线<8 AND (秒线<7.2 OR REF(秒线,1)<5) AND (短线>REF(短线,1) OR 秒线>REF(秒线,1)))
OR (长线<8 AND 短线<7 AND 秒线<15 AND 秒线>REF(秒线,1)) OR (长线<10 AND 短线<7 AND 秒线<1) ,COLORGREEN;
STICKLINE( 底域,-4,0,22,0 ),COLORRED;
低位金叉:50*(长线<15 AND REF(长线,1)<15 AND 短线<18 AND 秒线>REF(秒线,1) AND CROSS(秒线,长线) AND 秒线>短线
AND (REF(秒线,1)<5 OR REF(秒线,2)<5 )  AND (短线>=长线 OR REF( 秒线,1)<1 )),COLORRED;
涨停:=CLOSE/REF(CLOSE,1)>=1.0965;
MA13:=MA(C,13),COLORGRAY;
MA21:=MA(C,21),COLORWHITE;
支撑线:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
LC:=REF(CLOSE,1);
操作线:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*100;
趋势线:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;
震仓线:=45;
震仓线2:=50;
逃命线:=80;
抄底线:=20;
绝底线:=5;
PP2:=操作线<震仓线2  AND REF(操作线,1)>震仓线2 ;
PP:=操作线<震仓线  AND REF(操作线,1)>震仓线 ;
PP3:=操作线<抄底线  AND REF(操作线,1)>抄底线;
HH:=COUNT(涨停,13)>=1;
A5:=SMA(L,4,3) ;
DRAWTEXT_FIX(C>O,0.01,0.9,0,'王者说明 短线上穿长线,没有股票不涨的。'),COLORRED;
DIF1:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA1:=EMA(DIF1,9);
AAA1:=(DIF1-DEA1)*2*60;
AAA上:=IF(AAA1>REF(AAA1,1),AAA1,DRAWNULL);
AAA下:=IF(AAA1<REF(AAA1,1),AAA1,DRAWNULL);
入线:=15;
攻:=AAA1-REF(AAA1,1);
反转:CROSS(攻,入线);
STICKLINE(反转,0,50,1,0),COLOR00FFFF;
DRAWTEXT(反转,51,'反转'),COLORRED ;
VAR2:=(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100);
VAR3:=(((CLOSE - LLV(LOW,18)) / (HHV(HIGH,18) - LLV(LOW,18))) * 100);
VAR4:=SMA(VAR3,9,1);
VAR5:=SMA(VAR4,3,1);
趋势:=((3 * VAR4) - (2 * VAR5)), LINETHICK2 , COLORRED;
VAR6:=(趋势 > (1 * REF(趋势,1)));
VAR7:=LLVBARS(LOW,50);
VAR8:=SUM(VOL,VAR7);
VAR9:=HHVBARS(HIGH,50);
VAR10:=SUM(VOL,VAR9);
VAR11:=(((CLOSE - REF(OPEN,VAR9)) / REF(OPEN,VAR9)) * 100);
VAR12:=(((CLOSE - REF(OPEN,VAR7)) / REF(OPEN,VAR7)) * 100);
VAR13:=EMA(VAR4,3);
VAR200:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR300:=SMA(SMA(VAR200,3,1),3,1)/28.57;
VAR400:=EMA(VAR300,5);
操盘:=3*VAR300-2*VAR400;
AB1:=CROSS(操盘,VAR300) AND VAR300<2.1 AND C>O;
STICKLINE(AB1,30,0,1,0),COLOR0000FF;
DRAWTEXT(AB1,36,'共振'),COLORYELLOW;
SHORT:=12;LONG:=26;MID:=9;
EE:=MACD-REF(MACD,1)>0.05 AND
COUNT(C/REF(C,1)>1.09,16)<2 AND
C=HHV(H,60) AND
C/REF(C,1)>1.07 AND
NOT(H=L) AND
COUNT(C>O,6)<=4 AND
C/REF(C,9)<1.2,NODRAW;
STICKLINE(FILTER(EE,20),ABS(MACD)+1,80,1,0),COLORLIMAGENTA;
DRAWBAND(EE,RGB(255,0,0),0,RGB(0,255,0));
DRAWTEXT(EE,81,'吃三年'),COLORYELLOW;
SS:=MA((LOW+HIGH+CLOSE)/3,5)>REF(MA((LOW+HIGH+CLOSE)/3,5),1) AND
REF(MA((LOW+HIGH+CLOSE)/3,5),1)<REF(MA((LOW+HIGH+CLOSE)/3,5),2);
SC:=L<HHV(MA((LOW+HIGH+CLOSE)/3,5),13) AND
H>HHV(MA((LOW+HIGH+CLOSE)/3,5),13) AND C>REF(C,1) AND C>O;
MR:=SC AND COUNT(SS,2);
买:=MR AND NOT(REF(MR,1)),COLORYELLOW;
STICKLINE(买,L,L*0.95,1,0),COLORRED;
DRAWTEXT(买,L*0.95, '必涨'),COLORRED;

通达信控盘指标:控盘趋势指标公式

通达信控盘指标:控盘趋势指标公式



上一篇:通达信资金博弈指标
下一篇:通达信黑马选股公式:黑马均线主图公式
发表于 2018-1-2 00:12 | 显示全部楼层
感謝分享~~
回复

使用道具 举报

发表于 2018-1-2 09:01 | 显示全部楼层
谢谢分享
回复

使用道具 举报

发表于 2018-1-2 17:02 | 显示全部楼层
谢谢分享
回复

使用道具 举报

发表于 2018-1-3 15:32 | 显示全部楼层
谢谢分享
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

广告合作|VIP中心|网站地图|sitemap|手机版|archiver|股民大家庭 ( 辽ICP备17012147号-1 ) 24小时在线客服

GMT+8, 2018-1-19 03:56 , Processed in 1.199609 second(s), 35 queries , Gzip On.

Powered by Discuz! X3.2

© 2007-2017 Comsenz Inc.

股民大家庭股票论坛中国最大最好的股票论坛,11年专注股票论坛,专业提供股票交流股票软件股票公式等。
股民大家庭主要提供股票知识股票入门基础知识以及股票入门书籍知识学习的股票论坛
声明:股民大家庭上所有广告均为外来广告,所有的广告行为均与本站无关。
本站所有资讯均来源于网络,不作投资依据,仅供参考,据此入市,风险自担!
快速回复 返回顶部 返回列表